Fortress Forever

Go Back   Fortress Forever > Help & Technical > Server Administration

Reply
 
Thread Tools Display Modes
Old 11-02-2007, 03:01 PM   #1
Fathom
Guest
 
Posts Rated Helpful 1 Times
Server crashing after loading 1.1

Ever since I updated to 1.1 I cannot keep my server running. It has crashed randomly ever since. The server never had any problems running before the patch.

I have no idea what was changed in the update but it isn't working for me. This is a linux dedicated server. No mods are running, I removed meta and source mod and it still crashes. Before the patch the server had never crashed since 1.0 was released.

From what I've been able to see it's generally on a map change. I've shoved it on 1 map with extended time for now. It did however crash after about 3 hours of being full even at that.

Last edited by Fathom; 11-02-2007 at 05:40 PM.
  Reply With Quote


Old 11-02-2007, 03:32 PM   #2
Fathom
Guest
 
Posts Rated Helpful 1 Times
BTW I cannot find any mysterious. mdmp files. And nothing I see explains where these are to be found.

**Edit**

That's because there aren't any mdmp's on linux.

Last edited by Fathom; 11-04-2007 at 12:52 PM.
  Reply With Quote


Old 11-02-2007, 06:59 PM   #3
Fathom
Guest
 
Posts Rated Helpful 1 Times
Hmmm.. do the .mdmp files show up in the SDK FF directory? Or will those be in the CSS directory? All my host allows access to in FTP is the FF directory.

I will ask for access to the CSS directory if these files may be there.

**Edit**

No mdmp's on linux.

Last edited by Fathom; 11-04-2007 at 12:53 PM.
  Reply With Quote


Old 11-02-2007, 09:13 PM   #4
EquilibriuM
G9-
D&A Member
 
EquilibriuM's Avatar
 
Join Date: Sep 2007
Location: Florida
Class/Position: D Solly,Engy
Gametype: ALL
Posts Rated Helpful 0 Times
Yes they are in SDK BASE main folder.
__________________
EquilibriuM is offline   Reply With Quote


Old 11-03-2007, 03:56 AM   #5
Fathom
Guest
 
Posts Rated Helpful 1 Times
.... Do linux servers even have .mdmp files?

My host will not give me access to the SDK Source Base directory.
  Reply With Quote


Old 11-03-2007, 04:20 AM   #6
[AE] 82694
Retired FF Staff
 
[AE] 82694's Avatar
 
Join Date: Mar 2007
Posts Rated Helpful 0 Times
check this link out so you now what your looking for. I'm not sure if the #'s will be the same or not but you could ask them to put a copy of it in a temp folder so you can dl it.

link
__________________
I Love GenghisTron . I miss you sooooo Much. LOL.
[AE] 82694 is offline   Reply With Quote


Old 11-04-2007, 01:43 AM   #7
Fathom
Guest
 
Posts Rated Helpful 1 Times
mdmp's apparently not on linux servers??

Linux dump files:
http://www.ufgamers.com/files/coredumps.zip
  Reply With Quote


Old 11-04-2007, 04:39 PM   #8
Fathom
Guest
 
Posts Rated Helpful 1 Times
Freshly reinstalled everything. Still crashing on random map changes, in no pattern. Is there a windows utility that will allow me to read the core dumps.....
  Reply With Quote


Old 11-05-2007, 02:19 AM   #9
Fathom
Guest
 
Posts Rated Helpful 1 Times
http://www.ufgamers.net/files/coredumps2.zip
  Reply With Quote


Old 11-05-2007, 02:31 AM   #10
Fathom
Guest
 
Posts Rated Helpful 1 Times
http://www.ufgamers.net/files/coredumps2.rar
  Reply With Quote


Old 11-05-2007, 04:06 AM   #11
[AE] 82694
Retired FF Staff
 
[AE] 82694's Avatar
 
Join Date: Mar 2007
Posts Rated Helpful 0 Times
I'm running a linux server also and not one problem with crashes so far. Previously you said all the plug-ins were removed is this right or did I read wrong? I would try this if nothing else works. Reinstall FF 1.1 incremental patch. maybe you got a bad dl the first time. The AE Clan mirror on the front page is the same file I used to update my server and my client files.

Did you by chance update your server with the full version? If so there is a possibility that the 1.1 full version is windows only. If this is the case uninstall FF re upload the linux server package then upload the 1.1 incremental patch all should be good.
__________________
I Love GenghisTron . I miss you sooooo Much. LOL.

Last edited by [AE] 82694; 11-05-2007 at 04:13 AM.
[AE] 82694 is offline   Reply With Quote


Old 11-05-2007, 04:32 AM   #12
Fathom
Guest
 
Posts Rated Helpful 1 Times
I used the incremental. I originally had SM installed and metamod to run it of course. I've removed both of those.

I've reinstalled the incremental patch from two d/l sources now, no help.

I will try the one you suggested I have not d/l the patch from them.
  Reply With Quote


Old 11-05-2007, 03:01 PM   #13
Fathom
Guest
 
Posts Rated Helpful 1 Times
Well I d/l and installed the patch from the AE host as you recommended. It still randomly is crashing. The only thing modified now is the server title and rcon password.

Does anyone other than a fellow server host even give a shit? Seriously, I've supported this mod and supplied a good server since day 1. The least I could get is a reply as to what the dump's say. It's pretty hard to trouble shoot the POS with out some help, considering it's completely default now I have nothing to try. I can't keep re-installing it isn't doing anything.

Last edited by Fathom; 11-05-2007 at 03:19 PM.
  Reply With Quote


Old 11-05-2007, 05:20 PM   #14
TACO-BELL
 
TACO-BELL's Avatar
 
Join Date: Nov 2007
Posts Rated Helpful 0 Times
Dev guys please help Fathom sort this out. His UFG server is probably the most populated FF server hosted in the US (at least it was before 1.1) and the problems he's having affect not just himself but a very large chunk of regular FF players. Thanks!
TACO-BELL is offline   Reply With Quote


Old 11-05-2007, 05:48 PM   #15
DrEvil
Fortress Forever Staff
 
Join Date: Feb 2005
Location: Los Angeles, CA
Posts Rated Helpful 3 Times
I don't know how to debug linux crashes. If you could get a callstack with gdb I might be able to help. No idea what to do with linux core dumps, sorry.
DrEvil is offline   Reply With Quote


Old 11-05-2007, 08:39 PM   #16
Fathom
Guest
 
Posts Rated Helpful 1 Times
............................
  Reply With Quote


Old 11-06-2007, 01:10 AM   #17
[AE] 82694
Retired FF Staff
 
[AE] 82694's Avatar
 
Join Date: Mar 2007
Posts Rated Helpful 0 Times
Ok Fathom if you still have the FortressForever.tar.gz file I say put the server back to 1.0 and see if the server still crashes.

Have you put in a support ticket to your server provider and who is your gsp It might be a coincidence but the issue might be their's.

Did the crashing start as soon as 1.1 was installed? Which hl2 mod is your base server? Mine is hl2 dm.
__________________
I Love GenghisTron . I miss you sooooo Much. LOL.
[AE] 82694 is offline   Reply With Quote


Old 11-06-2007, 01:36 PM   #18
Fathom
Guest
 
Posts Rated Helpful 1 Times
Doesn't crash on 1.0 and the base source mod is CS:S for my server.

The host isn't very responsive thus far. They randomly keep asking "what changes have been made"........ I've told them numerous times.

I did ask if we could try the install from an HL2 DM base stead. So I guess I'll go from there. Otherwise I'm going to see about moving to a new box all together.

Last edited by Fathom; 11-06-2007 at 01:54 PM.
  Reply With Quote


Old 11-06-2007, 01:38 PM   #19
Fathom
Guest
 
Posts Rated Helpful 1 Times
It would be nice if someone could parse the dump files.....!
  Reply With Quote


Old 11-07-2007, 01:01 AM   #20
[AE] 82694
Retired FF Staff
 
[AE] 82694's Avatar
 
Join Date: Mar 2007
Posts Rated Helpful 0 Times
Ok Fathom I just got done playing on your server and as you know it crashed on map change. It was on ff_well so I had this problem once where I had a bad map name or missing map bsp file. So check your maplist.txt, mapcycle.txt and make sure all the bsb files for those are there. The server runs fine other wise so I don't think it's a 1.1 problem but maybe a typo or removed a map and forgot to take out of the mapcycle.txt.
__________________
I Love GenghisTron . I miss you sooooo Much. LOL.
[AE] 82694 is offline   Reply With Quote


Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.