Fortress Forever

Go Back   Fortress Forever > Editing > Modding

Reply
 
Thread Tools Display Modes
Old 12-12-2007, 12:32 AM   #1
pF
no war but class war
Fortress Forever Staff
 
pF's Avatar
 
Join Date: Oct 2007
Location: big bad berlin
Class/Position: Soldier / Scout
Gametype: ctf
Affiliations: [w~k!]
Posts Rated Helpful 3 Times
Viewmodels and attachments etc.

Hey everybody, i'm working on doing animations for the medkit viewmodel and i've run into problems getting the medkit to display in the game. A simple test animation displays correctly in the HL model viewer, but when i replace the standard medkit v_* files (and add slightly altered textures) with my compiled mdl stuff, there simply is no medkit to be seen in the game. Why is this? Do i need to have the bone structure set as 'child' to a certain default bone/attachment? Mistakes in the .qc file? What else could i be missing?

Thanks for any answers!
pF is offline   Reply With Quote


Old 12-12-2007, 01:21 AM   #2
omen
Retired FF Staff
 
Join Date: May 2006
Location: Norway
Posts Rated Helpful 0 Times
Its hard to guess, but if you'd send me the files i could have a look for you.
omen is offline   Reply With Quote


Old 12-12-2007, 02:45 AM   #3
pF
no war but class war
Fortress Forever Staff
 
pF's Avatar
 
Join Date: Oct 2007
Location: big bad berlin
Class/Position: Soldier / Scout
Gametype: ctf
Affiliations: [w~k!]
Posts Rated Helpful 3 Times
coolness - i'm at work right now, so i can't send anything, but i'll take you up on that offer later. what files do you need? smd and qc, or preferably the original XSI file?
pF is offline   Reply With Quote


Old 12-12-2007, 02:47 AM   #4
DrZer0
 
DrZer0's Avatar
 
Join Date: Oct 2007
Posts Rated Helpful 0 Times
try rotating each animation in the QC by 90 degrees

first try it -90 then 90 then if all else fails 180

Example

"$sequence Idle1 "Idle1" loop ACT_VM_IDLE 1 rotate -90 fps 30.00"
DrZer0 is offline   Reply With Quote


Old 12-12-2007, 03:03 AM   #5
omen
Retired FF Staff
 
Join Date: May 2006
Location: Norway
Posts Rated Helpful 0 Times
Quote:
Originally Posted by -pF-
coolness - i'm at work right now, so i can't send anything, but i'll take you up on that offer later. what files do you need? smd and qc, or preferably the original XSI file?
smd file's and qc should do it!
omen is offline   Reply With Quote


Old 12-13-2007, 02:32 AM   #6
pF
no war but class war
Fortress Forever Staff
 
pF's Avatar
 
Join Date: Oct 2007
Location: big bad berlin
Class/Position: Soldier / Scout
Gametype: ctf
Affiliations: [w~k!]
Posts Rated Helpful 3 Times
Hey omen - i've gotten a test animation to finally work in-game.. i think it was the missing $origin in the .qc, but to be honest i'm not really sure


Weird part is, only the medkit is moving, while the animation consists of tons more movement (fingers, wrists).. either i need to check my smd export options, or do some deep thinking!
pF is offline   Reply With Quote


Old 12-13-2007, 02:49 AM   #7
omen
Retired FF Staff
 
Join Date: May 2006
Location: Norway
Posts Rated Helpful 0 Times
ok, cool
omen is offline   Reply With Quote


Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.