View Single Post
Old 02-11-2016, 05:02 PM   #7
Server Owner
Join Date: Feb 2015
Location: New Zealand
Class/Position: Engineer / Heavy.
Gametype: Capture the Flag
Affiliations: {TALOS}
Posts Rated Helpful 75 Times
Originally Posted by FDA_Approved View Post
Download Source SDK Base 2013 Multiplayer. It should show up in your steamapps\common directory. Go in and copy the bin folder.(folder itself and everything in it.)

Paste but do NOT merge it into your Steam\steamapps\common\SourceSDK\bin\ep1 folder.

Take the option to rename instead of merge. Name it something like binMODEL. At this point you could probly just point wallworm to that folder. If not, when you want to model go in and rename bin to something like binMAPPING and rename binMODEL to bin.

I tried just merging the bins but it ended up breaking sdk tools for me, so i couldn't map or use the model viewer. Which is why I plan on doing this name juggling to keep everything happy.

I'm still having problems compiling vtfs as you were, but I think this is just a simple lack of proper pathing.

If you don't want to do the folder juggle, you could try just replacing studiomdl.exe and vtex.exe from your 2013 bin into your sdk bin. I haven't tried that but it was suggest by the wallworm fellow.

I managed to compile some models for fortress forever last night after running into the same compile error moto had. Copying new sdk exe's into the old bin is a cludge i wanted to avoid at all costs to i worked out the correct way to use our native 2006 studiomdl.exe.

To fix studiomdl.exe some files that moved during the steampipe update need to be moved back...

Copy C:\Program Files (x86)\Steam\config\SteamAppData.vdf to
C:\Program Files (x86)\Steam\steamapps\common\SourceSDK\bin\ep1\bin \config\SteamAppData.vdf

After moving this file i was successful in compiling using our native 2006 studiomdl.exe using the Notepad++ technique described here:

I know its a little late but i hope this helps anyone trying to compile models in future.

Last edited by Fat-Suzy; 02-11-2016 at 05:03 PM.
Fat-Suzy is offline   Reply With Quote

2 members found this post helpful.