Fortress Forever

Go Back   Fortress Forever > Projects > Fortress Forever > Bug

The dropped conc bug: (some video included) Issue Tools
issueid=237 11-19-2009 11:27 PM
The dropped conc bug: (some video included)

This has been annoying people for a while now. I've recently done some research into it and here are my findings.

First: This is not the nade timer sound bug happening after spawning!

One major reason I've included video is to minimize the amount of "are you really really sure it's not the timer sound bug? Watch the first run on the video:
  1. I spawn with 2 concs as a medic, as I should. If it were the timer bug I'd seem to only have one upon spawning
  2. I wait a few seconds after spawning. A timer bugged conc prime should go off by then.


I'm not accidentally hitting the prime nade button twice. To ensure this, I bound separate keys to primetwo and throwgren, so even if I hit the nade button 1000 times, it shouldn't drop unless I press the dedicated throw button.

(you probably wan't to double click on the video and watch it on the actual youtube site, in hq, and full screen. This way you'll actually be able to see something, and the watermark over the hud is gone.)

What's happening:

After dieing and respawning, the first conc I prime is immediately dropped, despite me not sending any nade-related commands. I've done a few experiments to try and determine the cause, and I think I'm on to something. Sometimes when I'm about to die while trying to kill a sentry gun, I rapidly press my throw nade button (bind <key> throwgren) to try and get an unprimed nade out after my primed nade before dieing. Every time this bug occurs, I was doing this prior to dieing, as shown in the video.
I've talked toseveral people who also have this bug, about 80% of them said they we're doing something similar to what I described, the other 20% gave an "um, not sure, don't think so" type response.

My theories:

I think some part of the throwgren code executed right before a player dies is being carried over after a player dies. Maybe:
  1. A conditional statement within the throwgren code is resolving "true" for determining whether or not a nade is actually primed, thus saying "ok, player is holding a nade (true), now throw the nade" But when this command reaches the server, you've already respawned and no longer have the nade that caused the statement to return true. The command would be "hanging," waiting for something to resolve it (like sending another command to prime a nade)
  2. throwgren is sending tons of cmd packets; more than cl_cmdrate (with sv_maxcmdrate) allows. Therefore some throwgren code is being delayed (between death to respawn) until more cmd packets are allowed.
  3. Something is being lag compensated that shouldn't be, ie: player presses throwgren before dieing, command gets to server after respawn (death/spawning doesn't obey the laws of lag compensation), server rewinds time to when nade was still in players hand, thinks "ok player had a nade, I''ll do the nade throwing code)

Other Notes
  1. I've talked to people who use both +gren2 (hold and let go) and toggletwo (double tap), both have users who experience the bug. I'm experiencing it with separate prime and throw keys, and I've tried the classic tfc "throwgren;primetwo" bind, which doesn't help either.
  2. It doesn't happen every time I die while pressing throwgren rapidly, however when it does happen, I was pressing throwgren rapidly prior to death.
  3. It seems to happen more often on laggy servers under load. I couldn't reproduce it on a uk server with only one other player, however it happens constantly on pubs with at least 8 players. It happens on <50ms populated servers as well.
  4. I tried some silly hacks, hoping I could inadvertently run into something that solves the problem :). I added "throwgren;wait;throwgren," -gren1, -gren2, and "cl_interpolate 0; wait;cl_interpolate 1" to my medic.cfg (separately). None worked :(.
  5. I tried setting my cmdrate so that it never sends more than the server can deliver, even if the server is lagging (ex on 66 tic server only giving me 40 cmds per second due to processing/maxrate, I set cmdrate to 40). It seemed to help actually, but I still got the bug. Might have just been luck.
Issue Details
Project Fortress Forever
Category General Game
Status Confirmed
Priority 3
Affected Version 2.4
Fixed Version (none)
Users able to reproduce bug 3
Users unable to reproduce bug 0
Assigned Users Elmo
Tags (none)

11-20-2009 03:13 PM
Nade Whore
Speaking of conc issues, what about when you are on a concmap, you are throwing a conc down a cliff of some sort right after priming it and it doesn't go off. It just disappears. Not sure if it's due to the speed it's going or just the amount of time it's in freefall, but it's annoying nonetheless.
11-22-2009 10:33 AM
internet user
removing any of the client side bool nade timers for the appropriate client when they die would probably be the easiest fix..

kube, can you make of a demo of this? I cant reproduce it on any conc maps i try. given I'm pretty bad at them
11-23-2009 04:21 AM
I get the same thing if I throw like 3 nades at a SG right before I die then respawn and try to conc, no matter how long I wait to prime the conc after I die it will still occur.
11-23-2009 02:41 PM
onE onE is offline
This used to happen to me, until i bought a new mouse, dont think it has happened since then.
11-23-2009 09:51 PM
Another issue with grenades (but mostly concs on concmaps) - if you mash grenades really fast, say two in half a second, you'll get the HUD icon and timer for the second nade, but it won't actually prime. Or even vice versa, you'll have it prime but not get the indication that it did (aside from the tiny click at the beginning, and watching your HUD).

I use doubletap, not sure if that'd cause it.
11-23-2009 11:52 PM
Kawaii! ルーキー
Originally Posted by KubeDawg
Speaking of conc issues, what about when you are on a concmap, you are throwing a conc down a cliff of some sort right after priming it and it doesn't go off. It just disappears. Not sure if it's due to the speed it's going or just the amount of time it's in freefall, but it's annoying nonetheless.
I've noticed something like this, by throwing my nade into a really fast push(that also affects rockets and grenades) it will just vanish. So it might be the speed?
11-27-2009 01:12 PM
Gets tickled by FF
I've changed this to confirmed cause its definitely a bug. Noticed it a lot more since you've said and only ever after I've been spamming at an SG before I die

Issue Tools
Subscribe to this issue

All times are GMT. The time now is 11:15 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.