Fortress Forever

Go Back   Fortress Forever > Projects > Fortress Forever > Bug

+attack2 function does not work properly Issue Tools
issueid=398 06-28-2012 03:18 AM
Nade Whore
+attack2 function does not work properly
Effects classes that use the Radial Menu as well as Soldier

Whether bound to a key or to a mouse button, using the +attack2 function sometimes does not work.

It's random, but here's what happens: (my +attack2 is currently bound to my mouse2 button)

As a Soldier, if I right-click to switch between my SShotty and my Rocket Launcher, more often than not, it will switch right back to the gun I had out initially. Example: RPG is out, I right-click, it switches to my SShotty and then immediately back to my RPG.

The same thing happens with classes like the Spy or Engineer where if you hold right click to disguise or build a SG, it exits the radial menu while you are still holding the key down.

I've seen this happen in previous versions of FF as well. Maybe it's the same issue?
Issue Details
Project Fortress Forever
Category General Game
Status Unconfirmed
Priority 3
Affected Version Undefined
Fixed Version (none)
Users able to reproduce bug 1
Users unable to reproduce bug 2
Assigned Users (none)
Tags (none)

06-28-2012 03:42 AM
 
Happened to me all the time. Stopped using attack2 to switch weapons. Never really notice it with medic, and don't play a lot of other classes. But It wouldn't make sense to notice it on medic unless I was trying to conserve med packs, because it seems that it just does attack2 twice some times, rather than not working.
Reply
06-28-2012 04:35 AM
 
I use Q often to rapidly switch between weapons (usually when I'm playing soldier or HW), and sometimes it refuses to work.
Reply
06-28-2012 10:41 AM
WhenNailGrenWillOut?
 
I don't know why, but I've never encountered problems like this. I use Q mostly to switch between RPG/SSG, sometimes mouse2 and this doesn't happen to me.
Reply
06-29-2012 03:25 AM
Nade Whore
 
Tested this again today and found the same issue happens with the Scout, too. When right-clicking to build a jump pad, occasionally it starts building it, then it just stops building. Definitely seems to be an issue with the +attack2 function.
Reply
08-01-2012 04:26 PM
Wiki Standards Team
 
I've noticed this happening with pyro too. I'll switch from IC to flamethrower and I'll somehow wind up with the IC again.
Reply
08-03-2012 06:09 PM
 
This has been a problem since the very beginning of FF i believe, so it would require rewriting the attack2 system (which is both risky and potentially a lot of work).

Alternatively we could hack it in by ignoring any keypresses past the first if they occur within 0.2 of a second of either other or something..
Reply
08-03-2012 06:22 PM
Nade Whore
 
This was actually working before the last FF patch though. Maybe something could be changed to make it work like in the previous version?
Reply
08-03-2012 06:34 PM
 
Are you 100% sure about that? I doubt we changed anything, although I guess it's possible with the overpressure being added.
Reply
08-03-2012 07:22 PM
Nade Whore
 
Yes I am pretty sure. I remember it being a problem in the past and the patch before last fixed it. It wasn't until this latest one that it started acting up again.
Reply
08-03-2012 07:34 PM
I like to spam binds
 
.
Reply
08-03-2012 07:55 PM
 
I disagree with Kube on patch specifics.
Reply
08-03-2012 10:55 PM
Nade Whore
 
It was fixed at some point. I can 100% remember that much. It may have been fixed in a patch before the previous previous one, but at this point, I really can't remember exactly which patch it was fixed.
Reply
08-04-2012 08:09 AM
Stuff Do-er
 
There's no way it was fixed. Been an issue in every patch I can remember.
Reply
08-04-2012 01:25 PM
Nade Whore
 
Well I guess that makes me crazy then, right? :D

I do remember it working correctly at some point for some reason though. I'll see if I can download the previous version of FF and test to see if it works or not.
Reply
08-07-2012 07:03 PM
exploder of things
 
kube words vs squeek words wonder(not) who will win? O_o
Reply
08-07-2012 10:23 PM
Stuff Do-er
 
Honestly, my word shouldn't be that definitive in this area since I almost never play demo/spy and really never use radial menus. Any demo that uses the radial menu to set detpacks should probably know, though.

I'm just saying the code that controls it hasn't really changed at all since pre-1.0, so I don't see how it could have been fixed.
Reply
08-07-2012 10:24 PM
 
<---Demo that uses the radial menu to set detpacks, it indeed has some issues.
Reply
08-08-2012 02:55 PM
exploder of things
 
Quote:
Originally Posted by CaptainAhab
<---Demo that uses the radial menu to set detpacks, it indeed has some issues.
I second that. Everytime I use it I swear that I will make a bind but never get around to it =(
Reply
08-10-2012 11:18 AM
 
It sucks, because you used to be able to use a bind to set a detpack and reload your pipes at the same time. Mr. "No-fun-allowed" squeek removed that last patch.

just kidding it's fine

I guess
Reply
12-29-2012 02:27 PM
Nade Whore
 
It's not an issue related to the radial menu, but the attack2 function. Same thing happens with the soldier's attack2 button. Switch to my Super shotty and it goes back to my RPG Launcher. If I open the radial menu, it exits out and I sometimes have to click multiple times in order to get it to stay on my screen, so it's somewhere in the attack2 function that causes it. I will continue to test previous FF builds as I keep remembering this being fixed at some point.
Reply
Reply

Issue Tools
Subscribe to this issue

All times are GMT. The time now is 11:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.